MSI motherboard woes

About a year ago, I built a computer based upon the MSI P45 Neo3-FR motherboard. I chose it because it offered the ICH10R chipset with Intel Matrix fakeraid (but that’s a whole other story).


At the time, I was disappointed with the board because I was not able to overclock – not one tiny bit. My CPU is an Intel Core 2 Quad Q8200, and many people had reported large gains in overclocking while still running at a low temperature and with excellent stability.

Naturally I wanted a slice of the overclocking pie – partly for the fun and satisfaction for doing it, and partly to get even more bang for my buck.

The MSI BIOS included lots of settings for overclocking and overvolting the RAM and CPU. However I quickly found that any change whatsoever caused the system to not boot. Of course I started off conservatively and I tried all sorts of combinations but I never got the system to boot with any settings other than the exact defaults.

I was disappointed, but ultimately it wasn’t a big deal. The Core 2 Quad system was still a massive step upwards from my former system – an AMD Athlon X2. Even running at factory settings, it ought to be a very capable system.


More recently, I’ve been wanting to build a Hackintosh. Fedora is a pretty damn good OS but there are one or two things it can’t do. For example, it doesn’t support my 35mm film scanner, and I can’t play my games.

OS X can do these things, and I greatly prefer it to Windows – even Windows 7, which is the best Windows in a long time, I reckon.

It’s a shame I hadn’t planned to make a Hackintosh before I bought the MSI motherboard, as I would have known that the most compatible boards are the Asus P5Q series.

Still, worth a shot with my P45-based board. I was able to get pretty far – I could get all the way through the OS X installer and it seemed fine. However, booting my freshly installed Snow Leopard caused it to freeze. I read millions of forums (not an exaggeration!) and it seemed that an incompatible BIOS might be the problem.

Some members recommended flashing with a custom-made BIOS, but I considered that a last resort. A sensible first step seemed to be to update to the latest MSI BIOS. Perhaps this alone would get my Hackintosh working and then I could ditch Windows as a secondary OS.

Live Update

MSI provide some Live Update utility that can allegedly update drivers and the BIOS from an ActiveX applet. Naturally it requires Internet Explorer on Windows, which as you can guess is not a combination I run on my computer. (However, I’ve never been able to make it work at all on any MSI-based system, Windows 7 or Vista)

Flashing the BIOS

The alternative is to download the BIOS image and the flashing program. It’s a Windows exe file. Of course Wine doesn’t help in this case because the program needs low-level access to the hardware. My only option is to boot from some kind of Windows media.

According to the readme file that came with the BIOS flashing program:

Boot your system from a Win98 or WinME boot-floppy.
How to make boot floppy in case your don’t have it ready:

  • For Win9X, You can type [C: format a:/s] from the DOS prompt.
  • For WinME, You can make a boot floppy from control panel–> add/remove program–>make boot floppy. Remove autoexec.bat & config.sys file if there’s any.
  • For Win2000, there’s no way to make boot floppy, so you have to either use Win9X or WinME boot floppy.
  • For WinXP, you can make a DOS boot disk. Go to Your Computer, right click drive A:, select Format, select copy system files.

If you do not have Windows ME or 98 to create the floppy you can make one on a friend’s computer.

Well that’s good, isn’t it. MSI officially recommend that I use a decade-old operating system on some hardware invented in 1983 (before I was bloody born!). Never mind the  fact that I don’t have a DOS boot disk, or a legacy Windows machine, or that my new computer doesn’t have a floppy drive. The solution? Oh it’s OK, I’ll go and ask a friend. Oops, scrap that – they all run BSD.

By chance, I have an IBM Thinkpad 760EL in my drawer, running Windows 3.11. Like all laptops of its era, it has a floppy drive, and being an IBM it still works perfectly. The battery life isn’t what it used to be but it still goes for half an hour and boots faster than a modern laptop running Vista. Of course it was easy to create a bootable DOS system disk.

Less straightforward was getting the BIOS program and image onto this bootable floppy. A straight-from-1991 copy of DOS 5.0 is unlikely to support USB mass storage, I reasoned. I managed to find an old floppy disk and connect it to my PC’s motherboard. My PSU didn’t have a floppy power connector so I had to make one by cutting up some old power cables and twisting the wires together. Finally I was able to boot into Fedora normally, mount the floppy disk and copy the files onto it.

Rebooting seemed to go OK and booting DOS didn’t cause any problems. After I got over my annoyance at the lack of tab completion, flashing the BIOS was easy. I powered off and on to make sure it had worked, and attempted to boot into Fedora.

Oh noes!

Apparently upgrading the BIOS didn’t go so smoothly after all. The new BIOS has more bugs than a dead dog in a New Delhi drain. It just…. doesn’t work.

  • My RAM, formerly clocked at its native speed of 1067MHz is now running at 800MHz and can’t be made to go faster.
  • My hard disks no longer work in AHCI mode. Random faults and reboots occur. I have to disable AHCI and go with IDE.
  • Onboard networking seems to have disappeared.
  • Any change to the hard disks (e.g. unplugging one, or swapping two over) cause the system to become non-bootable until the BIOS has been reset by pulling the jumper.
  • The CPU fan and case fans now always spin flat out, regardless of what the options are set to. This PC now sounds like a Dyson.

Seriously, if I wanted a computer with IDE disks, slow RAM and no networking, I’d still be using the Thinkpad. The fact that it has been in my drawer for years is a good indication that I do not want these things.

I’ve given up on building a Hackintosh on this hardware. It’s a world of pain. All I want is my old setup back, like it was this morning. However, I haven’t yet worked out how to fix this problem. Probably reverting to an older BIOS is the best way to go – unfortunately I didn’t make a note of which BIOS revision I was running before.

I had a look at the changelog of the various revisions to see if there was any that jumped out at me as a good one to try. Unfortunately there are loads, and even when you get your head around the Engrish, the changelog makes for pretty worrying reading. It’s full of things like this:

Fixed system report incorrect memory size when install 4G memory.

I mean, how on Earth did the original version that didn’t work with 4GB memory get past testing and find its way into a release? The fixed version came over 2 months after the previous version, too.

I guess I’m going to have to try and find a suitable BIOS revision through trial and error, just to get my old system functionality back. And then when I’ve got the spare cash, I will be replacing the board with an Asus P5Q, which will hopefully work with a Hackintosh build.

Oh, and maybe it will let me use AHCI, too.

MSI are useless.



To my delight I just found out that the motherboard is two weeks younger than one year old – so eligible for a warranty return. This is a real rarity – usually stuff breaks two weeks after the warranty period.

Ebuyer say I’m only entitled to a replacement, not a refund. However they no longer stock the MSI P45 Neo3 (must have been an unpopular model – can’t think why!) so it’s likely that I’ll get store credit and be able to pick a motherboard that works 🙂

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: